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INTRODUÇÃO

Este tutorial descreve passo a passo como construir um inversor e extrair os resultados dele. 
Não estamos utilizando o método mais rápido para isso, pois queremos ter contato com todas as 
regras de desenho. 
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OBJETIVOS

   0 – Descrever detalhadamente  como usei o Virtuoso, para que eu possa no futuro e em 
outros trabalhos poupar tempo. E também para que eu possa encontrar meus erros mais facilmente 
neste trabalho.

1-  Função  de  transferência  DC :  Vout  vs.  Vin  (curva).  Margens  de  ruído  High e  Low, 
calculadas a partir da função de transferência DC. 

2-  Valores  (em ps  = 10e-12 s)  dos  tempos  de  resposta  para  o  inversor  projetado  (para 
condições de carga tais que Fan-In = Fan-out = 1), a saber: Tphl, Tplh, Trise e Tfall. 

3- Potência consumida pelo Inversor projetado, à freqüência de chaveamento de Fo = 200 
MHz, utilizando o método explanado em a) , b) e c) abaixo. 

4- Cálculo da energia média (em pJ) consumida por  um (e apenas um) par de transições 
L →  H e  H →  L  por ciclo de clock. 

RESTRIÇÕES:

A altura centro a centro das linhas de VDD e GND deve ser 14u.
As linhas de VDD e GND devem ter 2u.
O transistor P deve ter 1,5x o tamanho do transistor N.
O L deve ser 0.35u
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DESENVOLVIMENTO

PREPARANDO O AMBIENTE:

Possua o sistema operacional Linux instalado corretamente no computador, acesso a Internet e uma 
conta no instituto de informática da UFRGS:

Abra o terminal:
Digite as seguintes linhas de comandos (use o seu e-mail não o meu):

ssh -X jwkmello@portal.inf.ufrgs.br 

É pedido a senha do instituto de informática. Uma vez logado precisa entrar no servidor do nscad:

ssh -X jwkmello@ufrgs-server-09.inf.ufrgs.br      

É pedido a senha da conta na nscad.

A primeira vez crie a seguinte pasta:
mkdir project.WA

Execute os próximos comandos:

cd project.WA

csh

source /scripts/start_ams_hk410.csh

A primeira vez execute o virtuoso assim:
ams_cds -tech c35b4
Na próxima vez que executar o virtuoso será necessário apenas digitar o seguinte comando:
ams_cds

OBS: na primeira janela quando se abre a primeira vez deve ser escolhida a opção C35B4CO PIP.
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CONSTRUINDO O ESQUEMÁTICO:
Quando inciar o Virtuoso pela primeira vez vai abrir uma janela apenas clique OK. 

Procure uma janela chamada Library Manager. Se ela não estiver aberta vá no console principal 
CIW e clique em Tools e ali tera o Library Manager.

Crie uma biblioteca com um nome qualquer, escolhi  “celulas”:

File →  New → Library...

Clique em:

OK

Apareceu a seguinte janela:
Marque a opção “Attach to an existing techfile”:

OK
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Na próxima janela marque a opção TEC_C35B4:

Ok

Agora feito isso podemos criar nossa célula,  primeiro selecione a biblioteca “celulas” clicando em 
cima dela no “Library Manager”. Depois no menu e faça o seguinte:

File →  New → Cell View …

Primeiro devemos criar o esquemático para o inversor. Em “Cell” dei o nome de “inversor”.

Em “Type” selecione “schematic”.
Em “Open with” selecione “Schematics XL”.  
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Uma tela preta para edição foi aberta. Então clique:

Create → Instance 

Clique em: 

Browse

Nos List Boxs escolha as opções:

PRIMLIB 
nmos4 
Symbol
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Mude o “Width” do transistor para 2u (ESCOLHA O SEU TAMANHO, ESTA NÃO É A 
MELHOR).

OBS: para editar depois uma instância já colocada no esquemático, basta selecionar ela e clicar q.
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Clique na tela aonde queira por transistor.

Clique em Hide para fechar as janelas.
 
Faça o mesmo para o pmos4. Escolhendo o “Width” maior , 3u. (wp = 1,5 wn, LEMBRO QUE 3u 
NÃO É O TAMANHO QUE TERÁ OS MELHORES RESULTADOS) 

Após isso faça as ligações que existem entre esses dois transistores utilizando a opção  “Create 
→Wire(Narrow)”, clique no local onde começa o fio, arraste o mouse até o local desejado e dê dois 
cliqueis para soltar o fio.

******DICAS*******
*Quando não estiver conseguindo fazer algo, experimente digitar algumas vezes a tecla ESC, pois 
assim o comando que você esta utilizando erroneamente é cancelado.

*Para apagar pressione Delete e clique com o mouse sobre a instancia ou fio que deseja apagar.
******DICAS*******

**DICA**
O cursor do mouse muda quando uma função está ativa. Fique atento para não fazer coisas 
indesejadas.
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Agora falta adicionar os pinos de VDD, GND , IN , OUT

Create → Pin

Dê aos pinos  os nomes utilizados acima, com letra maiúscula, em “Pin Names”.

VDD –> Direction  - “inputOutput”
   Signal Type - “power”

IN –> Direction  - “input”
   Signal Type  - “signal”

OUT –> Direction  - “output”
   Signal Type  - “signal”

GND –> Direction  - “inputOutput”
   Signal Type  - “ground”

Coloque os pinos e faça as ligações corretamente:
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Agora clique em:

Design  → Check and Save
Como não havia erros na janela de comandos apareceu uma mensagem de que não havia erros.
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CONSTRUINDO O SÍMBOLO: – ATENÇÃO EM SALA DE AULA FOI ENSINADO UM  JEITO 
BEM MAIS RÁPIDO.

Feito isso agora necessitamos criar um símbolo para o nosso esquemático. Para isso volte a janela 
“Library Manager”  selecione a biblioteca e o inversor, então:

File →  New → Cell View …

Nas combo boxs desta vez selecione: 

schematicSymbol

Symbol XL

Ok

Agora vamos desenhar nosso simbolo:

Create → Shape → Line

*Clique (Solte) – Arraste – Dois Cliques para soltar  a linha
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Agora criaremos os pinos:

Create → Pin...
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Crie os próximos pinos, exatamente como foram criados no esquemático. DEVEM TER O 
MESMO NOME.

VDD –> Direction  - “inputOutput”
   Signal Type - “power”

IN –> Direction  - “input”
   Signal Type  - “signal”

OUT –> Direction  - “output”
   Signal Type  - “signal”

GND –> Direction  - “inputOutput”
   Signal Type  - “ground”

Clique em File → Check and Save

Seu Símbolo deve ter ficado assim:
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SIMULAÇÃO DC:

1)

Agora faremos outro esquemático usando o simbolo do esquemático anterior para poder simular.
Feito isso estamos prontos para  simular o circuito, e obter a função de transferência DC (Vout vs 
Vin) e as Margens de Ruído.

Para isso crie uma nova célula.

File → New -> Cell View

Pus o nome de “inversor_simu_dc” e selecionei as opções “shematic” e “Shematics XL”.

Agora vá em:

Create → Instance

Browse

Selecione:

celula
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inversor
symbol

Tudo que fizemos foi pegar o  símbolo criado anteriormente.

Coloque ele no esquemático.
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Depois adicione um vdc (Fonte de alimentação para o inversor)

Create → Instance

Browse

Selecione:

analogLib
vdc
symbol

Para o parâmetro “DC voltage” atribua 3.3 V.
Coloque ele ligado no VDD. 

Adicione também 3 GND (terra). Um para cada fonte e um para o inversor.

Create→ Instance

Browse

Selecione:

analogLib
gnd
symbol
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Adicione também uma fonte de entrada para o inversor (”vdc”) onde no lugar de 3.3 V  coloque a 
variável “a”. Adicione também um pino de saída para o inversor.

 

Adicione um pino de IN de entrada e um OUT de saída.

Agora é só ligar tudo corretamente.
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Design - > Check and Save

Se não der nenhum erro estamos pronto para começar o processo de simulação respondendo ao item 
número 1 do trabalho.
 
Launch → ADE GXL

OK
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OK

Clique em here da opção Tests

OK
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Variables → Copy From Cell View

A variável “a” deve ter sido adicionado a janela do canto esquerdo:

Agora:

Analyses → Chosse...

Uma nova janela se abriu marque:

DC

Embaixo:

Design Variable

Clique em:

Select Design Variable

Escolha a variável “a”.
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Embaixo:

“Start” recebe 0 , “Stop” recebe 3.3

Em “Sweep Type” selecione “Linear” 

Marque a opção “Number of Steps”

No textbox ao lado você deve colocar um valor em torno de “132”.

Agora na janela principal de controle vá em:

Outputs  → To Be Plotted → Select On Schematic

Selecione os fios de entrada (IN) e a saída (OUT)

Falta agora escolher um valor para a:

Selecione “a” com um clique.

Vá em:

Variables → Edit
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Na janela que abrir:

Selecione o  “a” 

“Value (Expr)” recebe 3.3 então 

OK

Por fim:
Pressione o botão Verde.
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Eis a curva  Vout vs. Vin.

Agora iremos calcular as margens de ruído:

Tools → Calculator 

Marque a opção “Wave”.

Selecione a onda no gráfico , ela muda de cor e na calculadora aparece algumas coisas escritas. 

Depois escolha a opção “deriv”.
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Por fim Tools → Plot

Se tudo der certo o programa plotará o gráfico da derivada desta curva junto dela. Você pode 
separar os dois gráficos  clicando no quarto botão do Menu de Ferramentas.

Agora selecione a curva gerada, e vá  em:

26



Marker → Add

Na janela em que abrir , selecione “Horiz” em “Position(Y)” coloque -1.
Clique em ”Apply”. E uma janela irá abrir com os valores respectivos dessas posições, anote:

No nosso caso apareceu:

Vil  =   1.051
Vih =   1.639

Agora para calcular OUT selecione o gráfico de cima e:

Marker → Add

Na janela em que abrir , selecione “Vert” em “Position(X)” coloque 1.051 
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Como podemos ver:

Voh = 3.037

E para Vol faça:

Marker → Add

Na janela em que abrir , selecione “Vert” em “Position(X)” coloque 1.639
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Como podemos ver:

Vol = 284.9m

CALCULANDO AS MARGENS DE RUÍDO ALTA E BAIXA:

MRh = Voh - Vih = 3.037 – 1.639 = 1.398 V

MRl = Vil - Vol =  1.0515  - 0.2849 = 0.7666 V
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SIMULAÇÃO TRANSIENTE

2)

Agora iremos fazer a simulação transiente do nosso inversor para descobrir o Trise, Tfall , Tphl e 
Tplh. Para analise transiente precisamos de uma capacitância na saída. A análise transiente necessita 
de um inversor na saída e outro na entrada para assim tentar fazer o FanIn igual ao FanOut. A fonte 
de entrada agora sera uma Vpulse. 

Para isso crie uma nova célula.

File → New -> Cell View

E depois faça que nem nós fizemos anteriormente colocando uma fonte para a entrada chamada 
Vpulse e um capacitor na saída de 50f F.

Para adicionar a “vpulse” faça o seguinte:

Add → Instance

Browse

Selecionei:

analogLib
vpulse
symbol

Configurei as seguintes medidas para ele:
“Voltage 1” = 3.3 V
“Voltage 2” = 0.0 V
“Delay Time” = 0n s
“Rise Time” = 100p s
“Fall Time” = 100p s
“Pulse Width” = 2.5n s
“Period” = 5n s
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No mesmo “analoglib” seguindo os passos anteriores escolha um capacitor ”CAP” para saída e de o 
valor de 50f.
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Check and Save

Agora iremos simular o circuito. 

Design - > Check and Save

OBS: SEMPRE use Check and Save, e não apenas Save

Se não der nenhum erro estamos pronto para começar o processo de simulação respondendo ao item 
número 1 do trabalho.
 
Launch → ADE GXL

OK
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OK

Clique here em  Tests 
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OK

Analyses → Choose ...
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Na janela que abrir marque “tran” e em “Stop Time” coloque 10n.

OK
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Agora na janela principal de controle vá em:

Outputs  → To Be Plotted → Select On Schematic

Selecione o fio que entra no segundo transistor e o fio que sai do segundo transistor.

OBS: IMPORTANTE para facilitar a análise pode-se adicionar nomes aos fios clicando no seguinte 
botão no Editor.

Por fim:

Pressione o botão Verde.
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Temos aqui o nosso gráfico , agora estamos aptos a calcular tphl e tplh:

Vá em:

Marker → Create Marker...

Selecione “Horizontal” em “Position(Y)” coloque 1.65 que é 50% de 3.3, os pontos serão marcados.

Neste nosso exemplo a net11 é a saída do inversor logo o primeiro valor é o tphl pois a saída está 
descendo e a entrada subindo. E o segundo é o tplh pois ocorre o contrário.
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tphl = 158.18p – 112.62p = 45.56 ps
tplh = 2.7483n – 2.6916n = 0.0566n  = 56.6 ps

tp = (tphl + tplh) /2 = (45.56 + 56.6) /2 = 51.08ps

Agora iremos calcular o Trise e Tfall para isso marque retas em 10%  e 90% na voltagem, o Trise 
será tempo de 10% até 90% (quando a saída estiver subindo) e o Tfall será tempo de 90% - até 10% 
(quando a saída estiver descendo).
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Como podemos ver:

Tfall = 190.04p – 129.09p = 60.95ps

Trise = 2.814n – 2.7134n = 0.1006n = 100.6ps
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3)

Temos de calcular a potência consumida pelo inversor, a frequência de 200MHz que é o valor de 
5ns que escolhemos para fonte “vpulse”.

Na tela do gráfico vá em:

Tools → Calculator

Limpe qualquer valor dos cálculos anteriores.

Marque “it”

Selecione o quadradinho vermelho da segunda fonte no esquemático.

No textbox da calculadora vai aparecer ”IT” , multiplique por 3.3, pois P = VI. 

Selecione  “Average”

Pro fim Tools → Table

OBS: IMPORTANTE deve se medir a corrente do inversor CENTRAL.
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A potência é : 36.80uW

4)Por fim:

A energia média consumida é:

Energia = Potência * 5n (Duração do período , tempo para par de transições   L →  H e  H →  L  )

Energia = 36.80m * 5n = 36800n * 5 n = 184000 * 10^-18 J = 0.184pJ 
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CONSTRUINDO O LAYOUT:
Obs: Comando utéis
C –  copiar 
M – mover
ESC – cancelar comandos
F -  centralizar
S – modificar o tamanho dos quadrados clicando na borda
Clicando neste botão no Editor as regras de desenho serão mostradas no momento de criação do 
layout:

Selecione a biblioteca celulas no Library Manager, selecione o inversor, e clique File → New → 
Cell View ...

Type : layout
Open With: Layout GXL   ***IMPORTANTE ABRA COM O “GXL” PARA TER 
TODAS OPÇÕES***
OK

Vamos usar a régua para marcar  a altura da célula que foi pedida:

Tools → Create Ruler

Desenhe um linha de 14u, na marca de 1u e 13u desenhe um linha de alimentação de 2u. Neste 
espaço ficara as linhas de alimentação. Utilize MET1 drw para elas e pressione R para desenhar os 
retângulos.

Criando os retângulos:
*Clique (Solte) – Arraste – Clique novamente para soltar o retângulo

Feito um dos retângulos pressione C clique no retângulo e mova o mouse para cima, uma cópia do 
retângulos será criada.
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Em seguida crie a difusão do transistor Pmos e do transistor Nmos. O wp = 3u e o wn = 2u devem 
ser respeitados. Selecione o difusor DIFF drw pressione R e use a régua para posicioná-los.
De largura use 2,05u que é o mínimo que precisamos para colocar todos os seus elementos internos. 
Lembrar que neste desenho o W do transistor corresponde a altura do mesmo.
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******DICAS*******
Alguns comandos úteis que podemos utilizar para fazer os desenhos são:

*Pressionar “ESC” algumas vezes antes de usar a régua ou outra ferramenta para não ter nada em 
uso ou nada selecionado.

*Os comandos “Move” para mover, “Stretch” para modificar o tamanho do elemento já inserido na 
tela,  “Delete” para deletar alguns objeto, “Undo” para desfazer o último, “Zoom+” , “Zoom-” 

*E para limpar as réguas:
Window → Clear All Rulers
******DICAS*******

Agora colocaremos POLY1 que deve passar pelo centro das difusões, deve ter uma largura mínima 
de 0,35u e deve ultrapassar as difusões em 0,4u..
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Feito  isso  chegamos  na  parte  mais  aguardada  do  layout  a  construção  dos  contatos.  Para  isso 
selecione a layer  “CONT”. Os contados devem ter uma largura fixa de 0,4u e um comprimento fixo 
de 0,4u.

Eles também devem estar afastados no mínimo 0,4u um do outro. Deve haver 0,15u entre ele e a 
borda da difusão e 0,3u entre ele e o poli. Respeitando estas regras coloque o máximo de contados 
que couber dentro das difusões.
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Neste momento faremos o poço N utilizando “NPLUS”. O nplus deve ficar afastado da difusão de 
0,25u. Também faremos o poço P utilizando ”PPLUS” cuja  regra é a mesma. 

Agora faremos um poço “NTUB” para o transistor P , já que todo o inversor esta sobre um substrato 
do tipo P então da necessidade desse poço. O “NTUB” terá que ficar 1,2u da difusão.
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Então chegamos ao ponto de precisar fazer os poço n, com difusão e contados no VDD e o poço p, 
com difusão e contados no GND. Para acelerar o processo podemos usar o comando “Copy” e o 
“Stretch” (clicar S) nos objetos que eu já foram inseridos.
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Hora de adicionar as trilhas de metal ligando vdd e a difusão p , a difusão p e a difusão n , a difusão 
n e gnd.
A trilha deve ficar afastada da borda dos contatos no mínimo 0,15u e deve ter no mínimo 0,5u de 
largura e deve estar afastado no mínimo 0.45u de outra trilha de metal1.
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Agora é hora de criar os pinos.

Connectivity → Update → Components and Nets... 

Desmarca as opções Instances e PR Boundary
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Na aba I/O Pins:

Marque a opção Create Label As    Label

Clique em Options...
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Height – 0.2
Layer Name  - PIN
Layer Purpose - metal1

OK

OK

Então o esquemático deve se abrir , clique nos pinos e voltando o mouse para a tela de layout o  
pino aparecerá coloque cada pino só seu devido lugar. 

Para cada pino deve-se fechar o esquemático e repetir o procedimento.

Como os pinos estão em Metal1 deve-se colocar um CONTATO entre o pino IN e o poly.
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******MUITO IMPORTANTE***************

Para colocar o pino de IN é necessário colocar metal1 e um contato entre ele e o poly e encima 
deles é que se ponhe o pino de IN.

Os demais pinos basta largar encima da trilha de metal1.

******MUITO IMPORTANTE***************

Por fim o inversor ficou pronto:
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VERIFICANDO O LAYOUT E EXTRAINDO OS PARASITAS:

Agora veremos se ele não possui nenhum erro de violação as regras:

Asssura→ Run DRC...

Em “Switch Names”, pressione  “Set Switches” e escolha a opção “no_coverage”

OK

Se houver algum erro ele será mostrado na janela a direita e deverá ser corrigido, neste caso não 
houve nenhum erro.

Assura → Run LVS
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Se o passar no LVS, devemos rodar o LVS de novo com a opção 

Switch Names - resimulate_extracted  
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Agora devemos rodar o QRC para a extração dos parasitas:

Assura  → Run QRC

Na aba Extraction
Ref Node - GND
Extraction Type – RC
Max fracture length - 5
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OK
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Agora devemos rodar todas as simulações de novo usando o extraído:

Para isso selecione o esquemático da simulação DC no Library Manager e:

File → New →  Cell View...

Type – config

OK
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Na janela que abriu clique em Use Template

Selecione a opcção spectre.
OK
OK

Clique com o botão direito em celula  inversor

Set Cell View → av_extracted
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Clique em SALVAR. MUITO IMPORTANTE TEM QUE SALVAR ANTES 

Clique em Open na janela Top Cell

 

Pronto agora é só resimular seu circuito.
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RESULTADOS FINAIS

RESULTADOS DO ESQUEMÁTICO:

1)
Margens de ruído:
MRh = Voh - Vih = 3.037 – 1.639 = 1.398 V
MRl = Vil - Vol =  1.0515  - 0.2849 = 0.7666 V

2)
tphl = 158.18p – 112.62p = 45.56 ps
tplh = 2.7483n – 2.6916n = 0.0566n  = 56.6 ps

tp = (tphl + tplh) /2 = (45.56 + 56.6) /2 = 51.08ps

Tfall = 190.04p – 129.09p = 60.95ps
Trise = 2.814n – 2.7134n = 0.1006n = 100.6ps

3)
A potência é: 36.80uW

4)
Energia = 0.183pJ

RESULTADOS DO EXTRAÍDO:

1)
Margens de ruído:
MRh = Voh - Vih = 3.037 – 1.639 = 1.398 V
MRl = Vil - Vol =  1.050  - 0.2867 = 0.7633V

2) 
tphl =178.47p – 122.6p = 55.87ps
tplh = 2.7682n – 2.6985n = 0.0697n = 69.7ps

tp = (tphl + tplh) /2 = (55.87 + 69.7) /2 = 62.78ps

Tfall = 218.12p – 142.13p = 75.99ps
Trise = 2.8489n – 2.7251n = 0.1238n = 123.8ps

3)
A potência é: 44.72uW

4)
Energia = 0.223pJ
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